Magento

Magento é um sistema web de e-commerce open source baseado em PHP e MySQL utilizando elementos do Framework Zend, totalmente modular, desenvolvido pela Magento Inc (antiga Varien).

A Magento Inc foi adquirida pelo eBay em 2011. Mas em 22 de maio de 2018 a Adobe comprou por 1,68 Bilhão de dólares.

O Magento inclui todas as funcionalidades dos grandes players do mercado, com destaque para a otimização de sites (SEO) e a infinidade de módulos e extensões que podem ser utilizados.

Sua base de programação é sólida e modular, segura e escalável, provendo o suporte tecnológico necessário para que um e-commerce possa crescer de forma sólida e escalável.

Com mais de 250.000 lojas implantadas no mundo e presente em mais de 50 países, o Magento é considerada a plataforma de ecommerce mais popular do mundo.

Requisitos do servidor para Magento (versão 2.4):

Sistema Operacional . Distribuições Linux como RedHat Enterprise Linux (RHEL), CentOS, Ubuntu, Debian, etc. Não há suporte para Windows e macOS.
Requisitos de memória . Mínimo de 2 GB de RAM. Se você estiver usando menos de 2 GB de RAM, o Magento recomenda a criação de um arquivo swap.
Navegadores. Microsoft Edge, Firefox, Chrome, Safari.
Composer. última versão estável.
Servidores Web . Apache 2.4 ou NGINX 1.x.
Banco de dados . MySQL 8.0, MariaDB 10.4, Também compatível com MySQL 5.7.9, MariaDB 10.2 e Percona 5.7.
Versões do PHP . Magento suporta 2.4.0. Você ainda pode instalar o PHP 7.3 com Magento 2.4.0, mas não é oficialmente testado ou recomendado.
Extensões PHP . A seguir estão as extensões PHP que são necessárias para o Magento 2.4: ext-bcmath, ext-ctype, ext-curl, ext-dom, ext-gd, ext-hash, ext-iconv, ext-intl, ext-mbstring, ext-openssl, ext-pdo_mysql, ext-simplexml, ext-soap, ext-xsl, ext-zip, ext-sockets.
Segurança . É necessário um certificado SSL válido.
Dependências do sistema . Existe uma lista completa de dependências do sistema: bash, gzip, lsof, mysql, mysqldump, nice, php, sed, tar.
Tecnologias de cache . Certifique-se de que o PHP OPcache esteja ativado por motivos de desempenho. Use o Elasticsearch 7.6.xe o Redis 5.0 para cache de página e armazenamento de sessão. Varnish 6.x e RabbitMQ 3.8.x também são importantes!
Page 1 of 3 1 2 3